Phasing out old API, upgrade your WordPress plugins!

Last October we released a public beta of our new and much improved Rest API. Since then the API has evolved rapidly and is now considered stable and more than ready for production use.

The development of Flattr has been rather intense during the last 6 months and a lot of improvements have been made to the system. We have now reached a point where backwards compatibility with older versions of our APIs is no longer practical. Simply put our older Rest API versions have come to be a hindrance in the further development of our product and as a result we are now deprecating them.

How does this affect you?

Effective immediately we will no longer update or maintain versions 0.0.1 or 0.5 of the Rest API. Applications using our API will still function and remain active until April 14th 2012 when the APIs will be disabled. This gives you about a month to update your application to use the new Rest API(v2).

Note that if you are not the developer of the application that you are using, for example if you are using the WordPress plugin, then you need only upgrade to the latest version of the plugin. If a newer version of the plugin you are using does not exist I suggest that you contact the developer and inform them of the API changes.

If you have any questions then contact us through our contact form.


Not convinced that updating is a good idea? Here’s a few reasons for you:

* XML not required, we now also serve JSON, JSONP and YAML
* Regular updates featuring new resources and other improvements.
* We now use OAuth2 for authentication, which according to statistics is a gazillion times easier to implement.
* Actual documentation that is kept up 2 date with the code.

As you can see there are no reasons not to update!

4 thoughts on “Phasing out old API, upgrade your WordPress plugins!

  1. In response to Twitter feedback:

    It’s the WordPress plugins “presubmit” feature in versions prior to 0.99 that is affected. To my knowledge there aren’t any other plugins for any other tools out there that does any kind of “presubmitting”.

    Only users using a “presubmit” feature (that is – submitting things to Flattr.com through the API prior to them being flattred) should be affected by this.

    If you use an older version of the WordPress plugin and don’t use the presubmit feature then you should be fine – but upgrading to the latest version is of course always better anyway.

    So – eg. plugins for Drupal etc that doesn’t use our REST API isn’t affected by this change – plugins that only use our embeddable buttons and other non-REST API:s will continue to work just like before.

    (Regarding presubmitting eg. blog posts and such in general – there’s really no need for it as the things will get submitted when they are flattred – so an alternative to upgrading could also be to just stop using that feature)

  2. Ok that’s great. The wordpress maintainece are .Back Up,Checking Plugins,Updating etc..WordPress,Check Your Links,Improving Security etc..1) Backup your database and your files. You can use a number of plugins (Backup buddy is a good one) to do this, or if you trust your hosting company, there is often a file and database backup utility within your cpanel.2) Update plugins. This one is easy. Go to your plugins and look for any that need to be updated. All you need to do is click the update button and you’re done.3) Make sure you have the latest version of WordPress. WordPress will tell you on your dashboard if you need to upgrade. Simply follow the instructions – it’s not difficult.4) If you’re not using the akismet plugin, you can get it here – AKISMET . This will protect your site from spam.

Comments are closed.